aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1147e460..820de476 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,8 +39,10 @@ endif
# This is active if --enable-debug given to ./configure
# removed -Wduplicated-branches because needs gcc-8
if DEBUG
-DBG_CFLAGS = -Wextra -Wmisleading-indentation -Wduplicated-cond -Wlogical-op -Wnull-dereference -Wshadow -Wjump-misses-init -Wunused -Wsizeof-array-argument
-DBG_CXXFLAGS = -Wextra -Wmisleading-indentation -Wduplicated-cond -Wlogical-op -Wnull-dereference -Wshadow -Wunused -Wsizeof-array-argument
+DBG_CFLAGS = -Wextra -Wmisleading-indentation -Wduplicated-cond -Wlogical-op -Wnull-dereference \
+ -Wshadow -Wjump-misses-init -Wunused -Wsizeof-array-argument -Wparentheses
+DBG_CXXFLAGS = -Wextra -Wmisleading-indentation -Wduplicated-cond -Wlogical-op -Wnull-dereference \
+ -Wshadow -Wunused -Wsizeof-array-argument -Wparentheses
DBG_CPPFLAGS = -DDEBUG
else
DBG_CFLAGS =