aboutsummaryrefslogtreecommitdiff
path: root/gen/lib/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'gen/lib/Cargo.toml')
-rw-r--r--gen/lib/Cargo.toml14
1 files changed, 8 insertions, 6 deletions
diff --git a/gen/lib/Cargo.toml b/gen/lib/Cargo.toml
index b4f45b6b..2e400ffb 100644
--- a/gen/lib/Cargo.toml
+++ b/gen/lib/Cargo.toml
@@ -1,10 +1,11 @@
[package]
name = "cxx-gen"
-version = "0.7.93"
+version = "0.7.119"
authors = ["Adrian Taylor <adetaylor@chromium.org>"]
categories = ["development-tools::ffi"]
description = "C++ code generator for integrating `cxx` crate into higher level tools."
-edition = "2018"
+documentation = "https://docs.rs/cxx-gen"
+edition = "2021"
exclude = ["build.rs"]
keywords = ["ffi"]
license = "MIT OR Apache-2.0"
@@ -12,13 +13,14 @@ repository = "https://github.com/dtolnay/cxx"
rust-version = "1.60"
[dependencies]
-codespan-reporting = "0.11"
-proc-macro2 = { version = "1.0.39", default-features = false, features = ["span-locations"] }
-quote = { version = "1.0", default-features = false }
-syn = { version = "2.0.1", default-features = false, features = ["parsing", "printing", "clone-impls", "full"] }
+codespan-reporting = "0.11.1"
+proc-macro2 = { version = "1.0.74", default-features = false, features = ["span-locations"] }
+quote = { version = "1.0.35", default-features = false }
+syn = { version = "2.0.46", default-features = false, features = ["clone-impls", "full", "parsing", "printing"] }
[lib]
doc-scrape-examples = false
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
+rustdoc-args = ["--generate-link-to-definition"]