aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml37
1 files changed, 27 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5d42b0c6..c1806424 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,11 +1,11 @@
[package]
name = "cxx"
-version = "1.0.93" # remember to update html_root_url
+version = "1.0.119"
authors = ["David Tolnay <dtolnay@gmail.com>"]
categories = ["development-tools::ffi", "api-bindings", "no-std"]
description = "Safe interop between Rust and C++"
documentation = "https://docs.rs/cxx"
-edition = "2018"
+edition = "2021"
exclude = ["/demo", "/gen", "/syntax", "/third-party", "/tools/buck/prelude"]
homepage = "https://cxx.rs"
keywords = ["ffi", "c++"]
@@ -23,19 +23,19 @@ alloc = []
std = ["alloc"]
[dependencies]
-cxxbridge-macro = { version = "=1.0.93", path = "macro" }
-link-cplusplus = "1.0"
+cxxbridge-macro = { version = "=1.0.119", path = "macro" }
+link-cplusplus = "1.0.9"
[build-dependencies]
-cc = "1.0.49"
-cxxbridge-flags = { version = "=1.0.93", path = "flags", default-features = false }
+cc = "1.0.83"
+cxxbridge-flags = { version = "=1.0.119", path = "flags", default-features = false }
[dev-dependencies]
-cxx-build = { version = "=1.0.93", path = "gen/build" }
+cxx-build = { version = "=1.0.119", path = "gen/build" }
cxx-gen = { version = "0.7", path = "gen/lib" }
cxx-test-suite = { version = "0", path = "tests/ffi" }
-rustversion = "1.0"
-trybuild = { version = "1.0.66", features = ["diff"] }
+rustversion = "1.0.13"
+trybuild = { version = "1.0.81", features = ["diff"] }
[lib]
doc-scrape-examples = false
@@ -45,7 +45,24 @@ members = ["demo", "flags", "gen/build", "gen/cmd", "gen/lib", "macro", "tests/f
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
-rustdoc-args = ["--cfg", "doc_cfg"]
+rustdoc-args = ["--cfg", "doc_cfg", "--generate-link-to-definition"]
+
+[package.metadata.bazel]
+additive_build_file_content = """
+cc_library(
+ name = "cxx_cc",
+ srcs = ["src/cxx.cc"],
+ hdrs = ["include/cxx.h"],
+ include_prefix = "rust",
+ includes = ["include"],
+ linkstatic = True,
+ strip_include_prefix = "include",
+ visibility = ["//visibility:public"],
+)
+"""
+deps = [":cxx_cc"]
+extra_aliased_targets = { cxx_cc = "cxx_cc" }
+gen_build_script = false
[patch.crates-io]
cxx = { path = "." }