aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 15 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 20147e1..1c7f305 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.57"
+rust-version = "1.65"
name = "spki"
-version = "0.6.0"
+version = "0.7.3"
authors = ["RustCrypto Developers"]
description = """
X.509 Subject Public Key Info (RFC5280) describing public keys as well as their
@@ -32,7 +32,6 @@ categories = [
]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/RustCrypto/formats/tree/master/spki"
-resolver = "2"
[package.metadata.docs.rs]
all-features = true
@@ -41,13 +40,18 @@ rustdoc-args = [
"docsrs",
]
+[dependencies.arbitrary]
+version = "1.2"
+features = ["derive"]
+optional = true
+
[dependencies.base64ct]
version = "1"
optional = true
default-features = false
[dependencies.der]
-version = "0.6"
+version = "0.7.2"
features = ["oid"]
[dependencies.sha2]
@@ -56,7 +60,7 @@ optional = true
default-features = false
[dev-dependencies.hex-literal]
-version = "0.3"
+version = "0.4"
[dev-dependencies.tempfile]
version = "3"
@@ -66,6 +70,12 @@ alloc = [
"base64ct?/alloc",
"der/alloc",
]
+arbitrary = [
+ "std",
+ "dep:arbitrary",
+ "der/arbitrary",
+]
+base64 = ["dep:base64ct"]
fingerprint = ["sha2"]
pem = [
"alloc",