aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 9 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 685b30c..a65b7cc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,10 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
rust-version = "1.56"
name = "remain"
-version = "0.2.8"
+version = "0.2.12"
authors = ["David Tolnay <dtolnay@gmail.com>"]
description = "Compile-time checks that an enum, struct, or match is written in sorted order."
documentation = "https://docs.rs/remain"
@@ -21,32 +21,34 @@ readme = "README.md"
categories = [
"development-tools",
"no-std",
+ "no-std::no-alloc",
]
license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/remain"
[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
targets = ["x86_64-unknown-linux-gnu"]
[lib]
proc-macro = true
[dependencies.proc-macro2]
-version = "1.0"
+version = "1.0.74"
[dependencies.quote]
-version = "1.0"
+version = "1.0.35"
[dependencies.syn]
-version = "2.0"
+version = "2.0.46"
features = [
"full",
"visit-mut",
]
[dev-dependencies.rustversion]
-version = "1.0"
+version = "1.0.13"
[dev-dependencies.trybuild]
-version = "1.0.49"
+version = "1.0.81"
features = ["diff"]