aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 14 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4365648..b73c625 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.60"
+rust-version = "1.57"
name = "pkcs1"
-version = "0.7.5"
+version = "0.4.1"
authors = ["RustCrypto Developers"]
description = """
Pure Rust implementation of Public-Key Cryptography Standards (PKCS) #1:
@@ -45,23 +45,28 @@ rustdoc-args = [
]
[dependencies.der]
-version = "0.7"
+version = "0.6"
features = ["oid"]
[dependencies.pkcs8]
-version = "0.10"
+version = "0.9"
optional = true
default-features = false
[dependencies.spki]
-version = "0.7"
+version = "0.6"
+
+[dependencies.zeroize]
+version = "1"
+optional = true
+default-features = false
[dev-dependencies.const-oid]
version = "0.9"
features = ["db"]
[dev-dependencies.hex-literal]
-version = "0.4"
+version = "0.3"
[dev-dependencies.tempfile]
version = "3"
@@ -69,16 +74,15 @@ version = "3"
[features]
alloc = [
"der/alloc",
- "zeroize",
- "pkcs8?/alloc",
+ "pkcs8/alloc",
+ "zeroize/alloc",
]
pem = [
"alloc",
"der/pem",
- "pkcs8?/pem",
+ "pkcs8/pem",
]
std = [
"der/std",
"alloc",
]
-zeroize = ["der/zeroize"]