aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 26 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8a9436d..ae3d4fb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,20 +13,23 @@
edition = "2018"
rust-version = "1.37"
name = "pin-project-lite"
-version = "0.2.9"
+version = "0.2.13"
exclude = [
"/.*",
"/tools",
+ "/DEVELOPMENT.md",
]
description = """
A lightweight version of pin-project written with declarative macros.
"""
+readme = "README.md"
keywords = [
"pin",
"macros",
]
categories = [
"no-std",
+ "no-std::no-alloc",
"rust-patterns",
]
license = "Apache-2.0 OR MIT"
@@ -35,11 +38,32 @@ repository = "https://github.com/taiki-e/pin-project-lite"
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
+[lib]
+doc-scrape-examples = false
+
+[dev-dependencies.macrotest]
+version = "1.0.9"
+
+[dev-dependencies.once_cell]
+version = "=1.14"
+
+[dev-dependencies.proc-macro2]
+version = "=1.0.65"
+
+[dev-dependencies.quote]
+version = "=1.0.30"
+
[dev-dependencies.rustversion]
version = "1"
+[dev-dependencies.serde]
+version = "=1.0.156"
+
[dev-dependencies.static_assertions]
version = "1"
+[dev-dependencies.toml]
+version = "=0.5.9"
+
[dev-dependencies.trybuild]
-version = "1.0.49"
+version = "=1.0.67"