summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 18 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 79d715d..2a8ccdc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.56"
+rust-version = "1.61"
name = "pest"
-version = "2.5.6"
+version = "2.7.6"
authors = ["DragoČ™ Tiselice <dragostiselice@gmail.com>"]
description = "The Elegant Parser"
homepage = "https://pest.rs/"
@@ -26,9 +26,13 @@ keywords = [
"grammar",
]
categories = ["parsing"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/pest-parser/pest"
+[[bench]]
+name = "stack"
+harness = false
+
[dependencies.memchr]
version = "2"
optional = true
@@ -49,14 +53,21 @@ optional = true
version = "0.1.5"
default-features = false
+[dev-dependencies.criterion]
+version = "0.5.1"
+features = ["html_reports"]
+
[features]
const_prec_climber = []
-default = ["std"]
+default = [
+ "std",
+ "memchr",
+]
pretty-print = [
- "serde",
- "serde_json",
+ "dep:serde",
+ "dep:serde_json",
]
std = [
"ucd-trie/std",
- "thiserror",
+ "dep:thiserror",
]