aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 14 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a183443..9422901 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,39 +10,44 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.31"
+edition = "2021"
+rust-version = "1.56"
name = "no-panic"
-version = "0.1.21"
+version = "0.1.26"
authors = ["David Tolnay <dtolnay@gmail.com>"]
description = "Attribute macro to require that the compiler prove a function can't ever panic."
documentation = "https://docs.rs/no-panic"
readme = "README.md"
+categories = [
+ "no-std",
+ "no-std::no-alloc",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/no-panic"
[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
targets = ["x86_64-unknown-linux-gnu"]
[lib]
proc-macro = true
[dependencies.proc-macro2]
-version = "1.0"
+version = "1.0.63"
[dependencies.quote]
-version = "1.0"
+version = "1.0.29"
[dependencies.syn]
-version = "1.0"
+version = "2.0.23"
features = ["full"]
[dev-dependencies.rustversion]
-version = "1.0.9"
+version = "1.0.13"
[dev-dependencies.tempfile]
-version = "3.0"
+version = "3.6"
[dev-dependencies.trybuild]
-version = "1.0.69"
+version = "1.0.81"
features = ["diff"]