aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml29
1 files changed, 21 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0f43cb0..dad4126 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,32 +3,44 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "csv-core"
-version = "0.1.10"
+version = "0.1.11"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
description = "Bare bones CSV parsing with no_std support."
homepage = "https://github.com/BurntSushi/rust-csv"
documentation = "https://docs.rs/csv-core"
readme = "README.md"
-keywords = ["csv", "comma", "parser", "delimited", "no_std"]
-categories = ["encoding", "no-std", "parser-implementations"]
+keywords = [
+ "csv",
+ "comma",
+ "parser",
+ "delimited",
+ "no_std",
+]
+categories = [
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
license = "Unlicense/MIT"
repository = "https://github.com/BurntSushi/rust-csv"
+resolver = "2"
[lib]
bench = false
+
[dependencies.memchr]
version = "2"
default-features = false
+
[dev-dependencies.arrayvec]
version = "0.5"
default-features = false
@@ -36,6 +48,7 @@ default-features = false
[features]
default = []
libc = ["memchr/libc"]
+
[badges.appveyor]
repository = "BurntSushi/rust-csv"