aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 5 insertions, 21 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0ba7985..0a8fc81 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,10 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.38"
+edition = "2021"
+rust-version = "1.61"
name = "crossbeam-epoch"
-version = "0.9.14"
+version = "0.9.18"
description = "Epoch-based garbage collection"
homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-epoch"
readme = "README.md"
@@ -31,29 +31,13 @@ categories = [
license = "MIT OR Apache-2.0"
repository = "https://github.com/crossbeam-rs/crossbeam"
-[dependencies.cfg-if]
-version = "1"
-
[dependencies.crossbeam-utils]
-version = "0.8.5"
-default-features = false
-
-[dependencies.memoffset]
-version = "0.8"
-
-[dependencies.scopeguard]
-version = "1.1"
+version = "0.8.18"
default-features = false
[dev-dependencies.rand]
version = "0.8"
-[dev-dependencies.rustversion]
-version = "1"
-
-[build-dependencies.autocfg]
-version = "1"
-
[features]
alloc = []
default = ["std"]
@@ -68,6 +52,6 @@ std = [
]
[target."cfg(crossbeam_loom)".dependencies.loom-crate]
-version = "0.5"
+version = "0.7.1"
optional = true
package = "loom"