aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml37
1 files changed, 24 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4ec13d2..4ffa549 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,27 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
[package]
name = "bitreader"
-version = "0.3.6"
+version = "0.3.8"
authors = ["Ilkka Rauta <ilkka.rauta@gmail.com>"]
-
description = """
BitReader helps reading individual bits from a slice of bytes.
-You can read "unusual" numbers of bits from the byte slice, for example 13 bits
+You can read \"unusual\" numbers of bits from the byte slice, for example 13 bits
at once. The reader internally keeps track of position within the buffer.
"""
-
-documentation = "https://docs.rs/bitreader"
homepage = "https://github.com/irauta/bitreader"
-repository = "https://github.com/irauta/bitreader"
-
-keywords = ["bit", "bits", "bitstream"]
-
+documentation = "https://docs.rs/bitreader"
+readme = "README.md"
+keywords = [
+ "bit",
+ "bits",
+ "bitstream",
+]
license = "MIT OR Apache-2.0"
+repository = "https://github.com/irauta/bitreader"
-[dependencies]
-cfg-if = "1"
+[dependencies.cfg-if]
+version = "1"
[features]
-std = []
-
default = ["std"]
+std = []