aboutsummaryrefslogtreecommitdiff
path: root/pw_spi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pw_spi/CMakeLists.txt')
-rw-r--r--pw_spi/CMakeLists.txt59
1 files changed, 59 insertions, 0 deletions
diff --git a/pw_spi/CMakeLists.txt b/pw_spi/CMakeLists.txt
new file mode 100644
index 000000000..3ce4c3f1e
--- /dev/null
+++ b/pw_spi/CMakeLists.txt
@@ -0,0 +1,59 @@
+# Copyright 2023 The Pigweed Authors
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy of
+# the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+
+include($ENV{PW_ROOT}/pw_build/pigweed.cmake)
+
+pw_add_library(pw_spi.initiator INTERFACE
+ HEADERS
+ public/pw_spi/initiator.h
+ PUBLIC_INCLUDES
+ public
+ PUBLIC_DEPS
+ pw_assert
+ pw_bytes
+ pw_status
+)
+
+pw_add_library(pw_spi.responder INTERFACE
+ HEADERS
+ public/pw_spi/responder.h
+ PUBLIC_INCLUDES
+ public
+ PUBLIC_DEPS
+ pw_bytes
+ pw_function
+ pw_status
+)
+
+pw_add_library(pw_spi.chip_selector INTERFACE
+ HEADERS
+ public/pw_spi/chip_selector.h
+ PUBLIC_INCLUDES
+ public
+ PUBLIC_DEPS
+ pw_status
+)
+
+pw_add_library(pw_spi.device INTERFACE
+ HEADERS
+ public/pw_spi/device.h
+ PUBLIC_INCLUDES
+ public
+ PUBLIC_DEPS
+ pw_bytes
+ pw_spi.chip_selector
+ pw_spi.initiator
+ pw_status
+ pw_sync.borrow
+)