aboutsummaryrefslogtreecommitdiff
path: root/pw_span/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pw_span/CMakeLists.txt')
-rw-r--r--pw_span/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/pw_span/CMakeLists.txt b/pw_span/CMakeLists.txt
index 63cffd227..37e277ea1 100644
--- a/pw_span/CMakeLists.txt
+++ b/pw_span/CMakeLists.txt
@@ -24,7 +24,7 @@ pw_add_library(pw_span INTERFACE
public
PUBLIC_DEPS
pw_assert
- pw_polyfill.standard_library
+ pw_polyfill._standard_library
)
pw_add_test(pw_span.pw_span_test
@@ -37,7 +37,3 @@ pw_add_test(pw_span.pw_span_test
modules
pw_span
)
-
-if(Zephyr_FOUND AND CONFIG_PIGWEED_SPAN)
- zephyr_link_libraries(pw_span)
-endif()