aboutsummaryrefslogtreecommitdiff
path: root/examples/sdk/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sdk/CMakeLists.txt')
-rw-r--r--examples/sdk/CMakeLists.txt27
1 files changed, 1 insertions, 26 deletions
diff --git a/examples/sdk/CMakeLists.txt b/examples/sdk/CMakeLists.txt
index a2f74bd46..fc1385195 100644
--- a/examples/sdk/CMakeLists.txt
+++ b/examples/sdk/CMakeLists.txt
@@ -30,7 +30,6 @@ add_executable(example example.cc trace_categories.cc)
add_executable(example_system_wide example_system_wide.cc
trace_categories.cc)
add_executable(example_custom_data_source example_custom_data_source.cc)
-add_executable(example_console example_console.cc trace_categories.cc)
target_link_libraries(example perfetto
${CMAKE_THREAD_LIBS_INIT})
@@ -38,34 +37,10 @@ target_link_libraries(example_system_wide perfetto
${CMAKE_THREAD_LIBS_INIT})
target_link_libraries(example_custom_data_source perfetto
${CMAKE_THREAD_LIBS_INIT})
-target_link_libraries(example_console perfetto
- ${CMAKE_THREAD_LIBS_INIT})
# On Android we also need the logging library.
if (ANDROID)
target_link_libraries(example log)
target_link_libraries(example_system_wide log)
target_link_libraries(example_custom_data_source log)
- target_link_libraries(example_console log)
-endif (ANDROID)
-
-if (WIN32)
- # The perfetto library contains many symbols, so it needs the big object
- # format.
- target_compile_options(perfetto PRIVATE "/bigobj")
- # Disable legacy features in windows.h.
- add_definitions(-DWIN32_LEAN_AND_MEAN -DNOMINMAX)
- # On Windows we should link to WinSock2.
- target_link_libraries(example ws2_32)
- target_link_libraries(example_system_wide ws2_32)
- target_link_libraries(example_custom_data_source ws2_32)
- target_link_libraries(example_console ws2_32)
-endif (WIN32)
-
-# Enable standards-compliant mode when using the Visual Studio compiler.
-if (MSVC)
- target_compile_options(example PRIVATE "/permissive-")
- target_compile_options(example_system_wide PRIVATE "/permissive-")
- target_compile_options(example_custom_data_source PRIVATE "/permissive-")
- target_compile_options(example_console PRIVATE "/permissive-")
-endif (MSVC) \ No newline at end of file
+endif (ANDROID) \ No newline at end of file