aboutsummaryrefslogtreecommitdiff
path: root/shaders/glslx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shaders/glslx/Makefile.am')
-rw-r--r--shaders/glslx/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/shaders/glslx/Makefile.am b/shaders/glslx/Makefile.am
new file mode 100644
index 0000000..9be760e
--- /dev/null
+++ b/shaders/glslx/Makefile.am
@@ -0,0 +1,20 @@
+glslx_sources = \
+ shader_copy.comp.slx \
+ shader_geomap.comp.slx \
+ shader_gauss_scale_pyr.comp.slx \
+ shader_lap_trans_pyr.comp.slx \
+ shader_blend_pyr.comp.slx \
+ shader_reconstruct_pyr.comp.slx \
+ $(NULL)
+
+add_quotation_marks_sh = \
+ $(top_srcdir)/tools/add-quotation-marks.sh
+
+glsl_dir = $(top_srcdir)/shaders/glsl
+
+all-local: $(glslx_sources)
+
+$(glslx_sources): %.slx: $(glsl_dir)/%.sl
+ @$(add_quotation_marks_sh) $< $@
+
+CLEANFILES = $(glslx_sources)