aboutsummaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 0000000..c7630d2
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES = -I$(top_srcdir)/libusb
+noinst_PROGRAMS = listdevs
+
+listdevs_SOURCES = listdevs.c
+listdevs_LDADD = ../libusb/libusb-1.0.la
+
+if HAVE_SIGACTION
+dpfp_SOURCES = dpfp.c
+dpfp_LDADD = ../libusb/libusb-1.0.la
+noinst_PROGRAMS += dpfp
+endif
+
+if THREADS_POSIX
+if HAVE_SIGACTION
+dpfp_threaded_SOURCES = dpfp_threaded.c
+dpfp_threaded_CFLAGS = $(THREAD_CFLAGS) $(AM_CFLAGS)
+dpfp_threaded_LDADD = ../libusb/libusb-1.0.la
+noinst_PROGRAMS += dpfp_threaded
+endif
+endif
+