aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9eb7955..a12c0be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,9 @@
## Process this file with automake to produce Makefile.in
-AUTOMAKE_OPTIONS = foreign 1.6 dist-zip
+
+#AUTOMAKE_OPTIONS = foreign 1.6 dist-zip
+AUTOMAKE_OPTIONS = foreign 1.11 dist-zip dist-xz
+ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src include doc
@@ -10,10 +13,10 @@ m4data_DATA = ogg.m4
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = ogg.pc
-EXTRA_DIST = README AUTHORS CHANGES COPYING \
+EXTRA_DIST = README.md AUTHORS CHANGES COPYING \
libogg.spec libogg.spec.in \
ogg.m4 ogg.pc.in ogg-uninstalled.pc.in \
- macos macosx win32
+ win32 CMakeLists.txt cmake
dist-hook:
for item in $(EXTRA_DIST); do \
@@ -23,6 +26,17 @@ dist-hook:
echo "OK"; \
fi; \
done
+
+# Verify cmake works with the dist tarball.
+cmake_builddir = _build.cmake
+distcheck-hook:
+ $(RM) -rf $(cmake_builddir)
+ mkdir $(cmake_builddir)
+ cd $(cmake_builddir) && cmake ../$(top_distdir)
+ cd $(cmake_builddir) && cmake --build .
+ cd $(cmake_builddir) && ctest
+ $(RM) -rf $(cmake_builddir)
+
debug:
$(MAKE) all CFLAGS="@DEBUG@"