aboutsummaryrefslogtreecommitdiff
path: root/test/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'test/setup.py')
-rwxr-xr-xtest/setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/setup.py b/test/setup.py
index 7cbcc4a..b64f83e 100755
--- a/test/setup.py
+++ b/test/setup.py
@@ -17,6 +17,7 @@
from setuptools import setup, Extension
import os, sys, glob
+import numpy
if len(sys.argv) <= 1:
sys.argv = sys.argv + [
@@ -34,7 +35,7 @@ depends = [ 'ctypes.h' ] + \
glob.glob(INC_DIR + os.sep + '*.h') + \
glob.glob(SRC_DIR + os.sep + '*.[c,h]')
-includes = [ SRC_DIR, INC_DIR ]
+includes = [ SRC_DIR, INC_DIR, numpy.get_include() ]
extension = Extension('lc3',
extra_compile_args = [ '-std=c11', '-ffast-math' ],