aboutsummaryrefslogtreecommitdiff
path: root/perf/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'perf/meson.build')
-rw-r--r--perf/meson.build67
1 files changed, 51 insertions, 16 deletions
diff --git a/perf/meson.build b/perf/meson.build
index c3b0e3e4a..ae122f439 100644
--- a/perf/meson.build
+++ b/perf/meson.build
@@ -1,27 +1,62 @@
google_benchmark = subproject('google-benchmark')
google_benchmark_dep = google_benchmark.get_variable('google_benchmark_dep')
-ttf_parser_dep = null_dep
-if get_option('experimental_api') and add_languages('rust', required: false, native: true)
- ttf_parser_dep = subproject('ttf-parser').get_variable('ttf_parser_dep')
-endif
+benchmark('benchmark-font', executable('benchmark-font', 'benchmark-font.cc',
+ dependencies: [
+ google_benchmark_dep, freetype_dep,
+ ],
+ cpp_args: [],
+ include_directories: [incconfig, incsrc],
+ link_with: [libharfbuzz],
+ install: false,
+), workdir: meson.current_source_dir() / '..', timeout: 100)
-if ttf_parser_dep.found()
- benchmark_cpp_args = ['-DHAVE_TTFPARSER']
-else
- benchmark_cpp_args = []
-endif
+benchmark('benchmark-map', executable('benchmark-map', 'benchmark-map.cc',
+ dependencies: [
+ google_benchmark_dep,
+ ],
+ cpp_args: [],
+ include_directories: [incconfig, incsrc],
+ link_with: [libharfbuzz],
+ install: false,
+), workdir: meson.current_source_dir() / '..', timeout: 100)
-benchmark('perf', executable('perf', 'perf.cc',
+benchmark('benchmark-ot', executable('benchmark-ot', 'benchmark-ot.cc',
dependencies: [
- google_benchmark_dep, freetype_dep,
+ google_benchmark_dep,
+ ],
+ cpp_args: [],
+ include_directories: [incconfig, incsrc],
+ link_with: [libharfbuzz],
+ install: false,
+), workdir: meson.current_source_dir() / '..', timeout: 100)
+
+benchmark('benchmark-set', executable('benchmark-set', 'benchmark-set.cc',
+ dependencies: [
+ google_benchmark_dep,
+ ],
+ cpp_args: [],
+ include_directories: [incconfig, incsrc],
+ link_with: [libharfbuzz],
+ install: false,
+), workdir: meson.current_source_dir() / '..', timeout: 100)
- # the last two, thread and dl, aren't nice as ttf-parser isn't no_std yet
- # https://github.com/RazrFalcon/ttf-parser/issues/29
- ttf_parser_dep, thread_dep, cpp.find_library('dl'),
+benchmark('benchmark-shape', executable('benchmark-shape', 'benchmark-shape.cc',
+ dependencies: [
+ google_benchmark_dep, freetype_dep,
],
- cpp_args: benchmark_cpp_args,
+ cpp_args: [],
include_directories: [incconfig, incsrc],
link_with: [libharfbuzz],
install: false,
-), workdir: join_paths(meson.current_source_dir(), '..'), timeout: 100)
+), workdir: meson.current_source_dir() / '..', timeout: 100)
+
+benchmark('benchmark-subset', executable('benchmark-subset', 'benchmark-subset.cc',
+ dependencies: [
+ google_benchmark_dep,
+ ],
+ cpp_args: [],
+ include_directories: [incconfig, incsrc],
+ link_with: [libharfbuzz, libharfbuzz_subset],
+ install: false,
+), workdir: meson.current_source_dir() / '..', timeout: 100)