summaryrefslogtreecommitdiff
path: root/dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild')
-rw-r--r--dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild b/dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild
new file mode 100644
index 0000000000..770ea0be04
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,python_single_target_python2_7]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}