summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@google.com>2016-01-29 19:56:22 -0500
committerMike Frysinger <vapier@google.com>2016-02-01 02:06:40 -0500
commitf20e8cc6f1625b0196c0dac2dc3924cb14977ec6 (patch)
tree27b242b567097480d013dfa7b3da3675e20d8b93
parentac9e54689ad9b3fdc4c3dc3d2d0bcec65838ca50 (diff)
downloadintegration-f20e8cc6f1625b0196c0dac2dc3924cb14977ec6.tar.gz
make 3rd-party tools available w/out explicit packages
We don't need to hide the tools if no packages are opted in. This way we can still get `emerge` when requested and then we can run it by hand. BUG=b:26861037 TEST=default build doesn't include any tools TEST=adding 3rd-party-packages to PRODUCT_PACKAGES includes tools only TEST=also adding PRODUCT_3RD_PARTY_PACKAGES includes those packages Change-Id: I59a9eea6a6b3e0f15b0ca076be36340c786021e5
-rw-r--r--Android.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/Android.mk b/Android.mk
index 7798035..ed70f15 100644
--- a/Android.mk
+++ b/Android.mk
@@ -1,8 +1,5 @@
LOCAL_PATH := $(call my-dir)
-# Only load these subdirs when 3rd party packages have been requested.
-ifneq ($(PRODUCT_3RD_PARTY_PACKAGES),)
-
# Make sure they don't try putting quotes into the string.
# We'll take care of that for them.
ifneq (,$(findstring ',$(PRODUCT_3RD_PARTY_PACKAGES))$(findstring ",$(PRODUCT_3RD_PARTY_PACKAGES)))
@@ -90,6 +87,7 @@ include $(BUILD_SYSTEM)/base_rules.mk
LOCAL_BUILT_MODULE := $(intermediates)/$(LOCAL_MODULE)
$(LOCAL_BUILT_MODULE): $(LOCAL_ADDITIONAL_DEPENDENCIES)
$(hide)mkdir -p $(dir $@) $(TARGET_OUT_GENTOO)/tmp
+ifneq ($(PRODUCT_3RD_PARTY_PACKAGES),)
$(hide)\
printf '%s\n' $(3RD_PARTY_PACKAGES_QUOTED) | LC_ALL=C sort > $@.tmp; \
if cmp $@.tmp $@ 2>/dev/null; then \
@@ -102,6 +100,5 @@ $(LOCAL_BUILT_MODULE): $(LOCAL_ADDITIONAL_DEPENDENCIES)
--input-root $(3RD_PARTY_ROOT) \
--output-root $(TARGET_OUT) \
--make-root $(TARGET_OUT_GENTOO)/mk-installed
- $(hide)touch $@
-
endif
+ $(hide)touch $@