aboutsummaryrefslogtreecommitdiff
path: root/build_debian.sh
diff options
context:
space:
mode:
Diffstat (limited to 'build_debian.sh')
-rwxr-xr-xbuild_debian.sh15
1 files changed, 15 insertions, 0 deletions
diff --git a/build_debian.sh b/build_debian.sh
new file mode 100755
index 00000000..72dcfff9
--- /dev/null
+++ b/build_debian.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+# If this script fails on a Debian 4.0 ("etch") system then read
+# the debian/README.debian4 file.
+
+echo "chmod +x debian/rules"
+chmod +x debian/rules
+
+# in some environments the '-rfakeroot' can cause a failure (e.g. when
+# building as root). If so, remove that argument from the following:
+echo "dpkg-buildpackage -b -rfakeroot -us -uc"
+dpkg-buildpackage -b -rfakeroot -us -uc
+
+# If the above succeeds then the ".deb" binary package is placed in the
+# parent directory.