summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml101
1 files changed, 101 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..48924a7
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,101 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "gpio-cdev"
+version = "0.6.0"
+authors = [
+ "Paul Osborne <osbpau@gmail.com>",
+ "Frank Pagliughi <fpagliughi@mindspring.com>",
+]
+description = "Linux GPIO Character Device Support (/dev/gpiochipN)"
+homepage = "https://github.com/rust-embedded/gpio-cdev"
+readme = "README.md"
+keywords = [
+ "linux",
+ "gpio",
+ "gpiochip",
+ "embedded",
+]
+categories = [
+ "embedded",
+ "hardware-support",
+ "os",
+ "os::unix-apis",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-embedded/gpio-cdev"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[[example]]
+name = "async_tokio"
+required-features = ["async-tokio"]
+
+[dependencies.bitflags]
+version = "2.4"
+
+[dependencies.futures]
+version = "0.3"
+optional = true
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.nix]
+version = "0.27"
+features = ["ioctl"]
+
+[dependencies.tokio]
+version = "1"
+features = [
+ "io-std",
+ "net",
+]
+optional = true
+
+[dev-dependencies.anyhow]
+version = "1.0"
+
+[dev-dependencies.nix]
+version = "0.27"
+features = [
+ "ioctl",
+ "poll",
+]
+
+[dev-dependencies.quicli]
+version = "0.4"
+
+[dev-dependencies.structopt]
+version = "0.3"
+
+[dev-dependencies.tokio]
+version = "1"
+features = [
+ "io-std",
+ "rt-multi-thread",
+ "macros",
+ "net",
+]
+
+[features]
+async-tokio = [
+ "tokio",
+ "futures",
+]
+default = []