aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml31
1 files changed, 21 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8360666..624a2fa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,14 +10,24 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.58.1"
name = "glam"
-version = "0.20.3"
+version = "0.22.0"
authors = ["Cameron Hart <cameron.hart@gmail.com>"]
description = "A simple and fast 3D math library for games and graphics"
readme = "README.md"
-keywords = ["gamedev", "math", "matrix", "vector", "quaternion"]
-categories = ["game-engines", "no-std"]
+keywords = [
+ "gamedev",
+ "math",
+ "matrix",
+ "vector",
+ "quaternion",
+]
+categories = [
+ "game-engines",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/bitshifter/glam-rs"
@@ -53,11 +63,6 @@ name = "quat"
harness = false
[[bench]]
-name = "transform"
-harness = false
-required-features = ["transform-types"]
-
-[[bench]]
name = "vec2"
harness = false
@@ -72,6 +77,7 @@ harness = false
[[bench]]
name = "vec4"
harness = false
+
[dependencies.approx]
version = "0.5"
optional = true
@@ -110,6 +116,8 @@ optional = true
version = "1.0"
features = ["derive"]
optional = true
+default-features = false
+
[dev-dependencies.rand_xoshiro]
version = "0.6"
@@ -117,6 +125,7 @@ version = "0.6"
version = "1.0"
[features]
+core-simd = []
cuda = []
debug-glam-assert = []
default = ["std"]
@@ -125,11 +134,13 @@ glam-assert = []
libm = ["num-traits/libm"]
scalar-math = []
std = []
-transform-types = []
+
[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.criterion]
version = "0.3"
features = ["html_reports"]
+
[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
version = "0.3.0"
+
[badges.maintenance]
status = "actively-developed"