aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml29
1 files changed, 12 insertions, 17 deletions
diff --git a/Cargo.toml b/Cargo.toml
index abacbe2..577e9a7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,11 +11,12 @@
[package]
edition = "2018"
-rust-version = "1.36"
+rust-version = "1.38"
name = "crossbeam-epoch"
-version = "0.9.7"
+version = "0.9.13"
description = "Epoch-based garbage collection"
homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-epoch"
+readme = "README.md"
keywords = [
"lock-free",
"rcu",
@@ -33,28 +34,26 @@ repository = "https://github.com/crossbeam-rs/crossbeam"
[dependencies.cfg-if]
version = "1"
-[dependencies.const_fn]
-version = "0.4.4"
-optional = true
-
[dependencies.crossbeam-utils]
version = "0.8.5"
default-features = false
-[dependencies.lazy_static]
-version = "1.4.0"
-optional = true
-
[dependencies.memoffset]
-version = "0.6"
+version = "0.7"
[dependencies.scopeguard]
-version = "1.1.0"
+version = "1.1"
default-features = false
[dev-dependencies.rand]
version = "0.8"
+[dev-dependencies.rustversion]
+version = "1"
+
+[build-dependencies.autocfg]
+version = "1"
+
[features]
alloc = []
default = ["std"]
@@ -62,14 +61,10 @@ loom = [
"loom-crate",
"crossbeam-utils/loom",
]
-nightly = [
- "crossbeam-utils/nightly",
- "const_fn",
-]
+nightly = ["crossbeam-utils/nightly"]
std = [
"alloc",
"crossbeam-utils/std",
- "lazy_static",
]
[target."cfg(crossbeam_loom)".dependencies.loom-crate]