aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py78
1 files changed, 0 insertions, 78 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 5a10a61..0000000
--- a/setup.py
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/usr/bin/env python3
-
-# Copyright 2022 Google LLC
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# https://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-"""Custom mmi2grpc setuptools commands."""
-
-from setuptools import setup, Command
-from setuptools.command.build_py import build_py
-import pkg_resources
-import os
-
-package_directory = os.path.dirname(os.path.realpath(__file__))
-
-os.environ["PATH"] = package_directory + ':' + os.environ["PATH"]
-
-
-class BuildGrpc(Command):
- """gRPC build command."""
- description = 'build grpc files'
- user_options = []
-
- def initialize_options(self):
- pass
-
- def finalize_options(self):
- pass
-
- def run(self):
- from grpc_tools import protoc
-
- proto_include = pkg_resources.resource_filename('grpc_tools', '_proto')
-
- files = [f'pandora/{f}'
- for f in os.listdir('proto/pandora') if f.endswith('.proto')]
- protoc.main([
- 'grpc_tools.protoc',
- '-Iproto',
- f'-I{proto_include}',
- '--python_out=.',
- '--custom_grpc_out=.',
- ] + files)
-
-
-class BuildPyCommand(build_py):
- """Custom build command."""
-
- def run(self):
- self.run_command('build_grpc')
- build_py.run(self)
-
-
-setup(
- name='mmi2grpc',
- version='0.0.1',
- packages=['mmi2grpc', 'pandora'],
- install_requires=[
- 'grpcio',
- ],
- setup_requires=[
- 'grpcio-tools'
- ],
- cmdclass={
- 'build_grpc': BuildGrpc,
- 'build_py': BuildPyCommand,
- }
-)