aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8e54d32..a01b877 100755
--- a/setup.py
+++ b/setup.py
@@ -25,15 +25,14 @@ class BuildGrpc(Command):
proto_include = pkg_resources.resource_filename('grpc_tools', '_proto')
+ files = [f'blueberry/{f}' for f in os.listdir('proto/blueberry') if f.endswith('.proto')]
protoc.main([
'grpc_tools.protoc',
'-Iproto',
f'-I{proto_include}',
'--python_out=.',
'--custom_grpc_out=.',
- 'blueberry/host.proto',
- 'blueberry/a2dp.proto'
- ])
+ ] + files)
class BuildPyCommand(build_py):