aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 20 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 22f6e9f..5a10a61 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,21 @@
#!/usr/bin/env python3
+
+# Copyright 2022 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+"""Custom mmi2grpc setuptools commands."""
+
from setuptools import setup, Command
from setuptools.command.build_py import build_py
import pkg_resources
@@ -10,7 +27,7 @@ os.environ["PATH"] = package_directory + ':' + os.environ["PATH"]
class BuildGrpc(Command):
- """GRPC build command."""
+ """gRPC build command."""
description = 'build grpc files'
user_options = []
@@ -25,7 +42,8 @@ class BuildGrpc(Command):
proto_include = pkg_resources.resource_filename('grpc_tools', '_proto')
- files = [f'pandora/{f}' for f in os.listdir('proto/pandora') if f.endswith('.proto')]
+ files = [f'pandora/{f}'
+ for f in os.listdir('proto/pandora') if f.endswith('.proto')]
protoc.main([
'grpc_tools.protoc',
'-Iproto',