aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..6923987
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,14 @@
+[project]
+name = "mmi2grpc"
+authors = [{name = "Pandora", email = "pandora-core@google.com"}]
+readme = "README.md"
+dynamic = ["version", "description"]
+dependencies = ["grpcio >=1.41", "numpy >=1.22", "scipy >= 1.8"]
+
+[tool.flit.sdist]
+include = ["_build", "proto", "pandora"]
+
+[build-system]
+requires = ["flit_core==3.7.1", "grpcio-tools >=1.41"]
+build-backend = "_build.backend"
+backend-path = ["."]