aboutsummaryrefslogtreecommitdiff
path: root/src/microspdy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microspdy/Makefile.am')
-rw-r--r--src/microspdy/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/microspdy/Makefile.am b/src/microspdy/Makefile.am
new file mode 100644
index 00000000..7fb2c37f
--- /dev/null
+++ b/src/microspdy/Makefile.am
@@ -0,0 +1,40 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/microspdy
+
+AM_CFLAGS = $(HIDDEN_VISIBILITY_CFLAGS)
+
+
+lib_LTLIBRARIES = \
+ libmicrospdy.la
+
+libmicrospdy_la_SOURCES = \
+ io.h io.c \
+ io_openssl.h io_openssl.c \
+ io_raw.h io_raw.c \
+ structures.h structures.c \
+ internal.h internal.c \
+ daemon.h daemon.c \
+ stream.h stream.c \
+ compression.h compression.c \
+ session.h session.c \
+ applicationlayer.c applicationlayer.h \
+ alstructures.c alstructures.h
+libmicrospdy_la_LIBADD = \
+ $(SPDY_LIBDEPS)
+
+libmicrospdy_la_LDFLAGS = \
+ $(SPDY_LIB_LDFLAGS)
+
+libmicrospdy_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) $(SPDY_LIB_CPPFLAGS) \
+ -DBUILDING_MHD_LIB=1
+
+libmicrospdy_la_CFLAGS = -Wextra \
+ $(AM_CFLAGS) $(SPDY_LIB_CFLAGS)
+
+
+if USE_COVERAGE
+ AM_CFLAGS += --coverage
+endif